要问QoS哪家强,大佬们一致推荐ROS,但是这个系统并不怎么适合小白使用,所以这里介绍一种最简单的QoS方式:PCQ。

PCQ即PerConnection Queuing(每次连接排序),唯一一种能无等级排序的限流策略。PCQ会根据pcq-classifier参数产生子队列,每个子队列都有一个pcq-rate的数据率限制和pcq-limit大小的数据包。PCQ总大小不能大于pcq-total-limit

我家宽带情况:联通单线单拨,实测下行240Mbps,上行35Mbps。

前提条件:要完成基本配置,能上网,比如NAT,DHCP等配置好,然后再配置Queue。

第一步:标记数据

通过Firewall中Mangle的forward链表和prerouting链表,分别标记上传和下载的数据。

命令方式

# 标记上行数据包
# 注意out-interface改为你的WAN口名,如果使用PPPoE,那么就是你的PPPoE接口,一般是PPPoE-out1这种。
/ip firewall mangle add chain=forward action=mark-packet new-packet-mark=packet_upload passthrough=yes  out-interface=ether1 log=no log-prefix=""

# 标记下行数据包
# 注意的in-interface改为你的WAN口名,如果使用PPPoE,那么就是你的PPPoE接口,一般是PPPoE-out1这种。
/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=packet_download passthrough=yes in-interface=ether1 log=no log-prefix=""

Winbox方式

依次点开IP-Firewall-Mangle,添加两条规则。

标记上行数据包
forward
action

标记下行数据包
prerouting
action

第二步:配置Queue Type

QueueType直接用内置的就足够了pcq-download-defaultpcq-upload-default

第三步:配置Queue Tree

上行35Mbps,保留5M做缓冲,下行240Mbps,保留10M做缓冲,所以上行和下行最大限制分别为30M,230M

命令方式

/queue tree add name="download" parent=global packet-mark=packet_download limit-at=0 queue=pcq-download-default priority=8 max-limit=230M burst-limit=0 burst-threshold=0 burst-time=0s bucket-size=0.1
     
/queue tree add name="upload" parent=global packet-mark=packet_upload limit-at=0 queue=pcq-upload-default priority=8 max-limit=30M burst-limit=0 burst-threshold=0 burst-time=0s bucket-size=0.1

WinBox方式

upload
download

以上配置的效果是,如果只有一个用户使用,那么他可以享受230M下行和30M上行的网速,如果有两个用户,那么每个用户能够享受115M下行和15M上行的网速,以此类推。

最后修改:2020 年 09 月 22 日 09 : 48 AM